Installed, Dials, But No Ring

Sep 3, 2010 at 3:00 PM

I am running Outlook 2010 on Windows 7 64 bit.  I love the idea for VDialer, and it installed smoothly.  I configured the Add-In and the options appear properly. 

If I configure VDialer to use Vonage Contact Center API, then VDialer appears to dial the number, tells me the call was successful and opens a journal entry.  So everything looks good.  But the number dialed never rings and the phone I'm calling from just gives a dial tone.

If I configure VDialer to NOT use Vonage Contact Center API, then attempt to dial, the dialogue box just says "The number you are trying to dial from is invalid."

I really like the idea that this product tries to execute.  But for now its just not working.  Ideas?

Sep 3, 2010 at 3:47 PM

The usage of the Vonage Contact Center API is experimental, so it may stop working. I added this after the Click2Call API was down for a couple of months - unfortunately this is an unsupported API (in terms of Vonage) and is based on reverse engineering the server calls made on the Vonage Call Center web site. As such it may change from time to time and thus break the functionality.

It seems however that your telephone number is not correctly setup (i.e. the number to your Vonage phone). The Vonage service is a little bit picky about this - you should either use the "Lookup" button to retrieve the phone number or enter it on the form 1-(xxx)-xxx-xxxx (notice the long distance prefix).

If you live outside the US, I am not sure if this service will work for you - since I live in the US I cannot confirm, but I seem to remember seeing some posts about this. You can verify if the service works for you from your browser:

https://secure.click2callu.com/tpcc/makecall?username=username&password=password&fromnumber=fromNumber&tonumber=toNumber

Where:

username
The name that you use to log in to the Vonage dashboard
password
The password that you use to log in to the Vonage dashboard
fromNumber
Your Vonage phone number, this must match one of the numbers returned from the getnumbers request above
toNumber
The phone number you want to dial

The Click2Call web service documentation can be found here; https://secure.click2callu.com/ The page is sparse and looks amateurish - but it is a legitimate, Vonage operated page.

If you are still having problems, let me know and I'll can work with you to get this working.

Sep 3, 2010 at 4:29 PM

Thanks,

That worked.  I had just entered the phone number as straight digits without the 1 prefix.  Reentering the number with the format you specified fixed it.  I love this program!

Thanks again for such a great program and for your prompt and helpful reply.

Sep 3, 2010 at 5:39 PM

Great!

I did consider either forcing the user to use the lookup or validate the number, but came to the conclusion that if either the web service was down or Vonage decided to change the rules you would be stuck. I also tried to keep Canadian/UK users in mind, even if I am not sure this will work for those.

The feedback is appreciated, and if you have suggestions for improvements feel free to enter it either here or on the "Issue Tracker" tab. As long as I have some available time, I can usually incorporate them pretty quickly (provided they make sense, that is :-))

 

 

Sep 14, 2010 at 10:39 PM

Thank you for your suggestion - it works perfectly now.